Oauth flow not working anymore


We’re using the Oauth2 flow to let a Veeqo customer integrate with our customers solution. Usually we get requests to the specified callback after the customer accepts the Oauth2 Dialog.

Since a couple of weeks we’re receving either a callback request from the Veeqo system but with the “code” parameter being null , or we’re not receiving a call at all.

The integration worked already before that’s why we’re wondering if the issue is related to one of the questions below.

  1. Does our customer need to have any special partner account to make those integrations working?
  2. Does a Veeqo Customer (Merchant) be on a certain plan to be able to install 3rd Party Apps?
  3. Do you (Veeqo support) see anything in your logs what might go wrong here?

Our request has been forwarded to the Veeqo development team, but the answer was simply “I’ve been told by the support engineers that aren’t able to help with this sorry but they said you could try our developer forums here”

I’m looking forward to your thoughts.

Hello @vendor!
Thanks for raising this with the team.

Can you please provide your Application name and callback URL (as it is from your OAuth application)?


Hello @Kristien

is there a way to share the client_id and the callback URL on a private channel and not on a public forum? I’ve contacted already helpme@veeqo.com around 3-4 days ago, but without any response.

Team Itembase

@Kristien any update on the above topic?

@Kristien or anyone else from Veeqo, please get us some channel where we can share this sensitive information and to resolve this issue.

@vendor Have you tried sending your credentials to @Kristien via direct message? This is a Discourse-based forum so you can send private messages to other users. Click on the hamburger menu in the top-right and select inbox from the drop-down menu - you can send a private messages directly to @Kristien from the inbox page.

@DimuDesigns Thank you for the message. I can’t find any “Inbox” menu entry below the hamburger menu in the top-right.

Let me know if I’m missing anything.

That’s weird. That dialog should look like this:

But it seems you don’t have the messages and inbox options.

You can try getting to the personal messages dialog by clicking on your user profile icon and then the envelope icon:

You can also try clicking a user’s name to bring up a dialog with a message button:

Hopefully, one of those methods work.

Hello @DimuDesigns

We don’t have any of those options

  • No Envelope icon
  • No Message Button
  • No Inbox link.

I’m not sure if a certain “Badge/Status” is required to get those enabled. I just received one by communicating with you.

Thank you for your support!

@Kristien If there is any other channel that we can use to reach your developer support besides helpme@veeqo.com (where we still did not get any response), please let me know.

Good intuition. But its probably not related to badges, looking back at my forum notifications my ‘trust’ level was raised back in January '22 after I made a few posts/comments so maybe that’s the cause. @phil seems to be the person in charge of this forum so he’d be the one to ask. However I haven’t seen much activity from him of late (not sure if he’s still with Veeqo after Amazon acquired them). Maybe @Kristien can help with raising your trust level so that you can send private messages.

@phil @Kristien do you have any update on this topic?

Again, we don’t receive any response on any channel. Is that normal ?

I’m not sure if anything is wrong with our request we do have.

I’d appreciate any support.

Thank you!

I’ve reached out to you directly to assist with this.